系统之家
您现在的位置是:系统之家 > Ubuntu之家 > Ubuntu技巧 > 内容 RSS

ubuntu 15.04与ubuntu 16.04安装kde出错的解决办法

时间:2017-06-15 出处:系统之家 复制分享 人气(次) 【

我在ubuntu 15.04与ubuntu 16.04两个版本都希望一睹KDE的风采,所以sudo apt-get install kbuntu-desktop,但都一样出现包兼容的问题,卡死在install -f的提示上,运行修复则提示包冲突,结果继续卡死在install -f这一步。


以下为内容:
xxxxx@xxxxx-xxxxxx:~$ sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
正在修复依赖关系... 完成
将会同时安装下列软件:
kde-config-telepathy-accounts
下列【新】软件包将被安装:
kde-config-telepathy-accounts
升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
有 726 个软件包没有被完全安装或卸载。
需要下载 0 B/138 kB 的归档。
解压缩后会消耗 828 kB 的额外空间。
您希望继续执行吗? [Y/n] y
(正在读取数据库 ... 系统当前共安装有 239409 个文件和目录。)
正准备解包 .../kde-config-telepathy-accounts_4%3a15.08.2-0ubuntu1_amd64.deb  ...
正在解包 kde-config-telepathy-accounts (4:15.08.2-0ubuntu1) ...
dpkg: 处理归档 /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.08.2-0ubuntu1_amd64.deb (--unpack)时出错:
正试图覆盖 /usr/share/accounts/services/google-im.service,它同时被包含于软件包 account-plugin-google 0.12+15.10.20150914-0ubuntu1
dpkg-deb:错误:子进程 粘贴 被信号(断开的管道) 终止了
在处理时有错误发生:
/var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.08.2-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


原因:应该是上游问题。


解决办法:先用 sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade 更新所有软件包。

如还有问题可以直接强制覆盖,但 telepathy 账户可能无法正常工作:
apt-get -o Dpkg::Options::="--force-overwrite" -f install


相关资讯
最新资讯
热门内容
Ubuntu在vmare虚拟机无法上网的解决方法