系统之家
您现在的位置是:系统之家 > Ubuntu之家 > Ubuntu技巧 > 内容 RSS

Ubuntu安装xpenguins-2.2问题

时间:2017-06-15 出处:系统之家 复制分享 人气(次) 【

今天做Linux实验,下载xpenguins-2.2源码包实现解压,make安装。

下载没问题,http://xpenguins.seul.org/下载源码包xpenguins-2.2.tar.gz


下载文件夹下的情况:

adolph@adolph-vm:~/下载$ ls -l
总用量 272
-rw-rw-r-- 1 adolph adolph 275210 12月 11 13:01 xpenguins-2.2.tar.gz


解压命令:

sudo tar -zxvf xpenguins-2.2.tar.gz -C /usr/local/src


-C /usr/local/src表示解压到什么文件夹。 查看解压后的文件夹:

adolph@adolph-vm:/usr/local/src$ ls -l
总用量 8
drwxrwsr-x 23   427  6011 4096 12月 11 12:47 ntp-dev-4.2.7p482
drwxrwxrwx  4 13130 12824 4096 12月 11 19:16 xpenguins-2.2


进去文件夹,查看README文件,得出安装步骤:

32 Do the following:
33
34         ./configure
35         make
36         make install (as root)


根据步骤运行命令:

sudo ./configure


结果报错:


根据提示需要安装扩展包,这个例子是《鸟哥的私房菜》里的,鸟哥用的是红帽,所以网上给的处理方法:

yum -y install libXpm-devel
yum -y install libXext-devel

yum是红帽的安装软件命令,在Linux下不适用,软件包的名称也有差异


linux下的处理方法是:

sudo apt-get install libxpm-dev libxext-dev

一次安装两个扩展包就可以了。这时候再执行sudo ./configure就不会报错了。


相关资讯
最新资讯
热门内容
Ubuntu在vmare虚拟机无法上网的解决方法